How do you test a Duraspark pick-up assembly? - 460 Ford Forum
Engine Tech A place to discuss all 385-series engine tech and theory.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 03-22-2006, 08:57 PM Thread Starter
Member
 
Join Date: Jan 2006
Location: Regina,SK.,Canada
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
How do you test a Duraspark pick-up assembly?

I am not getting any spark out the Duraspark ignition on my truck and I think it is the pick-up coil as I have eliminated every other possibility I can think of and managed to isolate the problem to the distributor.When I measure the resistance across the coil I get about 540 ohms which is within specs and I also get infinite resistance between the wires going to the pick-up and ground.Is there another test I can do as I hate to replace it if it is good.
ifergusson is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-23-2006, 06:46 AM
Member
 
Join Date: Mar 2006
Posts: 222
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I saw a way to do this one time that I thought was pretty cool but can't remember everything about how he did it.
He basically hot-wired the engine and removed a plug wire and placed it near a ground. He then used a 110v electric razor and held it close to the pick-up in the distributor. That thing went crazy firing the plug wire. Might be more too it but that's all I remember. Worked like a charm though, I remember that and pretty much tested everything in the system.
clint

1971 Ford F100, 460/c6
PS, PDB, Auto, 3.0 gear
cdeal28078 is offline  
post #3 of 4 (permalink) Old 03-23-2006, 08:51 AM
Senior Member
 
Danny Cabral's Avatar
 
Join Date: Jan 2006
Location: Connecticut
Posts: 2,614
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
 
Let's test this the conventional way (using an ohmmeter). MSD uses the same type of magnetic pick-up coil as the Ford Duraspark:
http://www.msdignition.com/pdf/tech%...ic_trigger.pdf

May God's Grace Bless You

'78 BRONCO: 508" stroker, TFS heads, Dominator MPFI & DIS, cold air induction, dual 3" exhaust/Magnaflow mufflers, 100HP progressive dry direct-port NOS, A/C, Lentech Strip Terminator wide-ratio AOD, 3:1 Atlas II, modified Dana 44/60-lockers-4.10s, hydroboost/4-disc brakes, ram-assist/heim joint steering, Cage long radius arms, custom traction bars, 4" lift, 35" mud tires
Danny Cabral is offline  
post #4 of 4 (permalink) Old 03-28-2006, 08:46 AM Thread Starter
Member
 
Join Date: Jan 2006
Location: Regina,SK.,Canada
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I just thought I would post an update and maybe help someone else out with the same problem.The pick-up tested fine with an ohmmeter.I pulled the distributor and set up a temporary Duraspark ignition system on my workbench.If I used the distributor only as a triggering mechanism and put a spark plug at the end of the coil wire I had a good spark but if I routed the spark through the cap and rotor I got nothing.I replaced the cap and rotor with another one and it worked fine.I have never had a cap/rotor suddenly fail but that seemed to be the culprit.
ifergusson is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome