460 Ford Forum

460 Ford Forum (http://www.460ford.com/forum/index.php)
-   General Race Tech (http://www.460ford.com/forum/forumdisplay.php?f=48)
-   -   Engine won't pull R.P.M's (http://www.460ford.com/forum/showthread.php?t=164920)

fumotor069 07-21-2013 08:13 PM

Engine won't pull R.P.M's
 
I put the car away last fall running a best of 10.60's at 124 mph. I back the valves off for winter{ this is a solid cam} Did some upgrades to suspension, added motor plate,engine limiters, new headers, Sent converter back to be loosened up,sent my quick fuel E-85 carb to Horsepower Innovations to be reworked. I bring the car out after these upgrades now the car will leave good but falls on it's face.Will not pull above 5000-5500 RPM in any gear.
I have checked timing set at 34*,tried a different msd box, different coil, Disconnected tach and shift light.Did not help the problem.I have checked valve lash, has not changed. I am thinking valve springs may be weak.

zephyrbob 07-21-2013 11:49 PM

while my car is a full two seconds slower than yours it does the same thing. brick wall at 5200 to 5500. a fuel test at the carb showed not enough fuel volume. to top it off running the pump with the engine off also showed insufficient tank venting....bobn

fumotor069 07-22-2013 07:07 AM

I forgot to say I flow tested fuel system with the original a1000 fuel pump,did not flow enough.The fuel pump was old so I replaced with a new a1000 that flowed better than the old one. I tried putting the 2 a1000 pumps together and the regulator would not return enough fuel.I could not get fuel pressure under 11 psi. I bought an magnafuel 500 fuel pump and regulator.

butterbean 07-22-2013 09:31 AM

RPM
 
have you checked the vent on the tank? if so the only other thing I can think of is the valve springs, do you have a spring pressure tester? good luck

fumotor069 07-22-2013 07:30 PM

I checked the vent to fuel cell, was no blockage.I flow tested the fuel system with the cell cap off and on there was no flow difference, So i think that the vent is ok. I do have a valve spring tester.I will test the springs and see what happens. Thank you for all help. Larry

TRUKPULR 07-23-2013 04:26 AM

OK the big question is what did you turn for R's last fall before you put it away.

fumotor069 07-23-2013 04:45 AM

6200 rpm

MrScharfenberger 07-23-2013 09:32 AM

You said you had the carb worked on. It still sounds like a fuel starvation problem to me. Just not enough gas to keep it turning as quick as you need it to. I'd check the carb out again just to make sure. Maybe take it back to the guys that did the work and let them know what is going on and have them check it out.

fumotor069 07-23-2013 08:12 PM

I am thinking about trying a gas carb and see what happens. I just have a hard time paying $14-$16 a gallon for race gas.

frank13 07-24-2013 03:56 AM

pull a set of springs and check the pressure.

last year, I had the same issue, 5k rev limiter, pull the springs, checked them and poof, reading were way off. a couple shims later, poof 6500-7k no issues

fumotor069 08-12-2013 06:57 AM

I found the valve springs were weak, replaced them. Did not help. I was able to borrow a friend's e85 carb and the car is fixed ran 10.56 @126 mph. I have to send the carb back to be fixed now. Thank you for all the help, Larry

RaymondP 09-03-2013 07:30 AM

I'm having the same issue. What on the carb is the problem. My dominator works find but when l go to the smaller 750 it dies at 5000. I am on E85 as well

fumotor069 09-06-2013 06:40 PM

I sent the carb back. He took it a part and did not find why it did not work for me. He wants me to lock out the timing. He is putting a different tune in it that he said is too rich to drive on the street. My car is a track only car. I should have it back next week I hope.


All times are GMT -5. The time now is 01:10 AM.

Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.