My '78 bronco 460 - Page 2 - 460 Ford Forum
460 Ford Forum  
Go Back   460 Ford Forum > Tech Topics > Car Buildup Forum

Car Buildup Forum A place to detail your car build and chronicle your progress as you put together your BBF powered vehicle.

460Ford.com is the premier 460 Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 03-29-2014, 09:44 AM
mudbucket mudbucket is offline
Junior Member
 
Join Date: Jul 2012
Posts: 14
mudbucket First On Race Day
Default

Removing timing chain cover for the first time , I have all the bolts out and crankshaft pulley off ,I can pry away the top of the cover but it feels like its binding on something. Any hints , I don't see anything that should be hold it on except the gasket material. Can it be that stubborn ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17  
Old 03-29-2014, 09:54 AM
nord315 nord315 is offline
Member
 
Join Date: Dec 2010
Location: North Dakota
Posts: 88
nord315 First On Race Day
Default

I know that you said that you have removed all the bolts, by chance did you forget to remove the front oil pan bolts that go into the front cover?
Reply With Quote Quick reply to this message
  #18  
Old 03-29-2014, 11:40 AM
mudbucket mudbucket is offline
Junior Member
 
Join Date: Jul 2012
Posts: 14
mudbucket First On Race Day
Default

Yes ,I did miss those,good thing I didn't get carried away prying it.
Thanks
Reply With Quote Quick reply to this message
  #19  
Old 03-29-2014, 12:45 PM
mudbucket mudbucket is offline
Junior Member
 
Join Date: Jul 2012
Posts: 14
mudbucket First On Race Day
Default

Got the cover off and saw this .
[IMG][/IMG]

Isn't this timing set to 0* ?
Reply With Quote Quick reply to this message
  #20  
Old 04-01-2014, 06:40 PM
mudbucket mudbucket is offline
Junior Member
 
Join Date: Jul 2012
Posts: 14
mudbucket First On Race Day
Default

This looks better
[IMG][/IMG]
Reply With Quote Quick reply to this message
  #21  
Old 04-01-2014, 07:54 PM
butterbean butterbean is online now
Senior Member
 
Join Date: Dec 2012
Location: Naples, Fl.
Posts: 978
butterbean First On Race Day
Default

that is the straight up one
Reply With Quote Quick reply to this message
  #22  
Old 04-02-2014, 06:09 PM
mudbucket mudbucket is offline
Junior Member
 
Join Date: Jul 2012
Posts: 14
mudbucket First On Race Day
Default

First time doing this and I am having a tough time believing that I can get the timing chain cover on and aligned without having it leak , plus I got I think have the wrong crankshaft seal ,my old one didn't have the flange .
[IMG][/IMG]
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:00 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.