My 460 Torino conversion - Page 2 - 460 Ford Forum
460 Ford Forum  
Go Back   460 Ford Forum > Tech Topics > Car Buildup Forum

Car Buildup Forum A place to detail your car build and chronicle your progress as you put together your BBF powered vehicle.

460Ford.com is the premier 460 Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 08-21-2013, 06:49 PM
1972Mach1's Avatar
1972Mach1 1972Mach1 is offline
Senior Member
 
Join Date: Aug 2009
Location: Hamilton, MT
Posts: 588
1972Mach1 First On Race Day
Default

Quote:
Originally Posted by White Lightning View Post
Auggie, as a general rule, the major santioning groups won't let you run juice with a forced induction. Have you checked into that? Not to mention that means that your bottom end will REALLY have to be up to snuff.
Rob
Rob, would they let a guy run if he had the bottle pulled? Haven't ever run something like that, so I have no idea.

Lucas
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17  
Old 08-21-2013, 07:09 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

Quote:
Originally Posted by White Lightning View Post
LOLOLOLOLOLOL. I keep tryin' to tell everyone that I'm such a nice guy that they should give me presents.........but so far it hasn't worked! lol
Rob
Not True!! You got pushrods!! Hell I even delivered them to Alaska...


Keep them as long as needed. I'm just razzing you cuz it's fun!!

Reply With Quote Quick reply to this message
  #18  
Old 08-21-2013, 07:10 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

Quote:
Originally Posted by 1972Mach1 View Post
Rob, would they let a guy run if he had the bottle pulled? Haven't ever run something like that, so I have no idea.

Lucas
Pulled? As in out of the car? Yes. At least they do around these parts anyways.
Reply With Quote Quick reply to this message
  #19  
Old 08-21-2013, 07:15 PM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default NOS

So far I only test and tune. The boost will be 75-100hp max.

I run nos in my Cobra, 427FE but not much because it really isn't needed either.

All they can do is tell me no and to pull the bottle and the lines will just look pretty. But on Super Nationals weekend it's pretty much a free for all up here.

Also, because the bottom end IS still a 2bolt, something that will be remedied over the winter, and the rods are ford hi po rods with ARP bolts and mains are ARP studs...... I was thinking with the extra blower pulleys and can keep it under driven so the boost still stays at the 5-7 lb range with just a light shot at the end to see how much it actually cools it down. I have o2 sensors but I'm running 2 pyrometers to watch the temp. I prefer pyrometers over o2s when it come to heat. but the combination of the two will let me know if I'm leaning out at the end and how hot I'm running.

But it's easier to put the plate on now than after it's all set up, lol. Like I said... all they can do is say no. lol......

When it's time to actually try and race someone without looking silly going so slow.... then I will get my rule book back out and read up on what I can do. Till then it's just experimenting
Reply With Quote Quick reply to this message
  #20  
Old 08-21-2013, 07:25 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

GOOD LORD MAN!! That fogger is serious business!!

I hope you are wearing old underwear when you try it out for the first time!!


And by the way...... SWEET!!

Reply With Quote Quick reply to this message
  #21  
Old 08-21-2013, 07:27 PM
1972Mach1's Avatar
1972Mach1 1972Mach1 is offline
Senior Member
 
Join Date: Aug 2009
Location: Hamilton, MT
Posts: 588
1972Mach1 First On Race Day
Default

Nitrous is addictive ....I had it on my old Cleveland and I miss the switch. Playing with the idea of putting it on top of the 552, but I need to run it in the 1/4 and see what it does. If it's close to a point, like say I run 11.1s in the quarter, I'll give it a little taste to get in the 10's.....

Looking better and better, sir. Get that beast done.

Lucas
Reply With Quote Quick reply to this message
  #22  
Old 08-21-2013, 07:49 PM
blu69machI's Avatar
blu69machI blu69machI is offline
Member
 
Join Date: Oct 2011
Location: Omaha, Nebraska
Posts: 80
blu69machI First On Race Day
Garage
Default

Man, this ride is beastly as hell. I can't wait to see it complete again. Beautiful car.
Reply With Quote Quick reply to this message
  #23  
Old 08-21-2013, 07:52 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

That sounds like a TON of fun!

I have a Big Shot plate system for mine. I'll put it on eventually after I get used to the car itself. Keep it up!! You are almost there.

...it must be nice to have Summit so close. I have family up in Cleveland and I stopped at the Talmadge Summit on the way back in June. I've been to the one south of Atlanta too many times to count. I wish they were right down the street from me!! I could spend a day in that place just checking out all of the unboxed on the shelf parts. I love that place!
Reply With Quote Quick reply to this message
  #24  
Old 08-22-2013, 01:26 PM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default new look

Ok, from the picture on the first page to now.... this is going to be the look after it's finished........

















Next two pics are extra parts I may or may not be getting rid of when complete




Last edited by ag460torino; 08-31-2013 at 01:03 AM. Reason: pics
Reply With Quote Quick reply to this message
  #25  
Old 08-22-2013, 07:30 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

That looks great sticking out of the hood. I love the fogger setup!

Are you going to paint the block? But I guess you can't see the red and blue with the hood shut.

Last edited by MrScharfenberger; 08-22-2013 at 08:14 PM.
Reply With Quote Quick reply to this message
  #26  
Old 08-22-2013, 08:00 PM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default ppaint

actually, the alum block mount plate covers that whole section. That's why it is the way it is. So I'm not too worried. If some red peeks out I will just touch it up then, lol...
Reply With Quote Quick reply to this message
  #27  
Old 08-22-2013, 08:13 PM
MrScharfenberger's Avatar
MrScharfenberger MrScharfenberger is offline
Senior Member
 
Join Date: Dec 2009
Location: Georgetown Indiana
Posts: 3,669
MrScharfenberger First On Race Day
Default

Quote:
Originally Posted by ag460torino View Post
actually, the alum block mount plate covers that whole section. That's why it is the way it is. So I'm not too worried. If some red peeks out I will just touch it up then, lol...
That completely went right by me. I didn't think about that.
Reply With Quote Quick reply to this message
  #28  
Old 08-22-2013, 08:32 PM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default

it's always the simple things that get us the most! lol
Reply With Quote Quick reply to this message
  #29  
Old 08-29-2013, 12:23 PM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default



While degree-ing cam I was running into a "clicking" coming from the lifter/rocker areas. Nothing regular. The noise would move around or not even click at all for several rotations. Very frustrating. Long story short, the new rocker geometry was off from the rockers I had and the pushrods would click when going from full closed to opening position. Note the gold (new rocker) in pic of degree-ing and silver (rockers I already had) in the later photo....



So I am going back together now. The next pic shows just how close the Hampton blower was to fitting on the Hampton intake. Look at the rear blower mount holes to the intake stud holes....



One last note... look at the casted build date on the bottom of the blower I removed......



5/22/67.............. Now that's a classic!!! And still builds great boost!!!

So now I'm off to the trailer to get back to work. It's coming along but a little slower than I would have liked.

You all have a good one and I'll be back!!!


Last edited by ag460torino; 08-29-2013 at 12:49 PM.
Reply With Quote Quick reply to this message
  #30  
Old 08-31-2013, 12:47 AM
ag460torino's Avatar
ag460torino ag460torino is offline
Senior Member
 
Join Date: Dec 2012
Location: N.E. OHIO
Posts: 534
ag460torino Bleeding Blue
Default

Ok, intake on and cooling system buttoned up. Hit Summit today for a new dizzy, wires and LOTS of fittings to do plumbing. Also got the twin NO2 tank holder today.

Will get distributor in and blower on tomorrow. Mounting the injection hat/nitrous plate combo will be a little trickier due to all the nos lines crossing where the injection lines go.

Then it's mounting the fuel pump, filter, surge tank, primer and running all the lines ....... SIMPLE!
Coming along. Getting anxious and a little scared..... Running blower was new to me.... now tuning the injection will be new to me. Still have to mount 2 short pipes on headers to run evac hoses too and to mount the pyrometers and the O2 sensor. Those WERE mounted in the custom exhaust pipes that I removed for testing. Would like to mount them back on if everything works out and I know they won't create a back pressure problem.

Will update soon with more photos........
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:29 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.