Disaster at WFC 10!!! - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old 05-21-2007, 12:13 PM Thread Starter
 
Join Date: Nov 2006
Posts: 414
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Disaster at WFC 10!!!

Yes the weather was excellent at WFC 10. The crowd was light and the car count seemed down. Except in Wild Street! 41 cars looking to make the 32 car field. Only 28 made it. I was one of them but only due to a crazy course of events...

Thursday I ran a nice 10.70. Friday I went to make a similar pass (time trials) and as I did a 5000 RPM burnout a retainer broke! The valve met the piston and bent the (*^% out of it. I motored down the track, cause it sounded like a plug wire fell off to me from in the car. Back at the pit it was grim. I almost packed it in. But we started pulling it apart and got the head off - still hot!
So with a busted part and a bit of hope I bummed a ride to the edelbrock display. You guys have seen this thing, right? A huge semi with all of their products very neatly displayed, but nothing much for sale. Well, I talked to Ron, the edelbrock guy and we worked out a deal (it wasn't as easy as I make it look) in exchange for my broken parts I got some parts from the display!!!! Thanks Ron!!! And everyone at the edelbrock trailer.
Here is where Nos-stang jumped in and saved the day- the valve guide was bent and the new valve wasn't going in right. He had the right drill bit to clean up the busted part! 11/32" in case anyone was wondering. Thanks Greg!! Did I mention Kevin for taking me to his house and getting me a head gasket?! He also showed me around to the local parts stores for a spring compressor.
The piston looked pretty good so we put it back together getting done around 11pm. The next day the 30 mile cruise went flawlessly. I made the three passes and made the field. Unfortunately the 'stang went out in the first round... But it did drive at the end of the weekend, thanks to all that helped :!:
the1969fordguyinky is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-21-2007, 12:30 PM Thread Starter
 
Join Date: Nov 2006
Posts: 414
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Oh I forgot the car show! Yeah I double dipped!!!!

http://www.photoreflect.com/scripts/...um=0&adjust=-1

I meant raced and showed...
the1969fordguyinky is offline  
post #3 of 7 (permalink) Old 05-21-2007, 02:11 PM
Senior Member
 
Phantasea466's Avatar
 
Join Date: Jan 2006
Location: Lawrenceburg, KY
Posts: 6,697
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by the1969fordguyinky
Oh I forgot the car show! Yeah I double dipped!!!!

http://www.photoreflect.com/scripts/...um=0&adjust=-1

I meant raced and showed...
Uh- Huh :mrgreen:

Glad you guys got it fixed.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Damon Sea
1983 Mustang
534ci

"If it doesn't fit, Force it. If it breaks then it needed to be replaced anyway"
http://photobucket.com/albums/f75/Phantasea466
Phantasea466 is offline  
 
post #4 of 7 (permalink) Old 05-21-2007, 02:23 PM
Member
 
F570.RD's Avatar
 
Join Date: Jan 2006
Location: mpls mn
Posts: 177
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I too felt the pain of breakage.A rod let go at 1100' and caused a silent track for nearly an hour on Thursday. :cry: Great time was had though talking with folks.Just happy the car was not scuffed.
F570.RD is offline  
post #5 of 7 (permalink) Old 05-21-2007, 07:08 PM
Senior Member
 
Join Date: Jan 2006
Posts: 1,317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
 
james your car was awesome! nice to met ya besides. i also managed to stop in northern indiana to meet f250 mike.
.....i ran my car in et3, all runs i made were with in .08 .....won one round, lost one....lol bobn
zephyrbob is offline  
post #6 of 7 (permalink) Old 05-21-2007, 10:50 PM
Senior Member
 
Duane's Avatar
 
Join Date: Jan 2006
Location: Arlington, TX
Posts: 479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Hey, some of those great pictures had cars in the backround! :lol:
Duane is offline  
post #7 of 7 (permalink) Old 05-22-2007, 07:19 AM Thread Starter
 
Join Date: Nov 2006
Posts: 414
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Good to meet you too Bob. I never did get a chance to get over to your car.

:shock: there are cars in those pictures? I like the photomagic site, tons of photos and usually timed just right.
the1969fordguyinky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome