Electric Fuel Pump Location Question? - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 9 (permalink) Old 08-06-2007, 01:46 PM Thread Starter
 
Join Date: Jun 2007
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Electric Fuel Pump Location Question?

I am really pressing hard to wrap up the fabrication / restoration phase of my '59 Ranch Wagon chassis, so I can fire up the motor and move on to other parts of the project. This morning while I was looking through the technical information for my Holley HP 150 electric fuel pump, I noticed where it said to mount the pump so the inlet/outlet are lower than the fuel cell, so the pump can be gravity fed. Whoops- the mount I fabricated for the pump puts it ~4" higher then the lowest point of the fuel cell (see pictures below). Is this placement going to ruin the pump by requiring it to suck the fuel from the tank? Thanks in advance for your help.



1959Ford is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 08-06-2007, 01:52 PM
dfree383
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
I'd remount it lower, while you still can do it with out a whole bunch of hard work and finding out later its causing trouble.
post #3 of 9 (permalink) Old 08-06-2007, 02:06 PM Thread Starter
 
Join Date: Jun 2007
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Yeah- you're right. I need to stop and take a breath. I just hate missing a small detail, and ending up having to do things twice. It's a minor thing in the grand scheme, but still annoying. However, it needs to be fixed correctly. Sorry for hitting the panic button... :roll:
1959Ford is offline  
 
post #4 of 9 (permalink) Old 08-06-2007, 06:03 PM
Senior Member
 
Join Date: Jul 2006
Location: Cheraw, SC
Posts: 724
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Two things I notice right off. I would turn the cell around 180 degrees. Going uphill might require a push. Another thing try to use as few 90s as possible. Each one on the suction side of the pump causes a pressure drop in the suction line. On extremely hot days it may lower the suction enough to create a vacuum lowering the boiling point of gas. You want liquid not gas vapor. Never use the tight forged one piece 90s on the suction line. They are the worse. The tube 90s are ok, but try to use only one.
Monstermiler is offline  
post #5 of 9 (permalink) Old 08-06-2007, 06:11 PM
dfree383
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
He makes a good point, the sump should face to the rear, not the front.
post #6 of 9 (permalink) Old 08-06-2007, 06:38 PM Thread Starter
 
Join Date: Jun 2007
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I spent the time to move the fuel pump to a better location (see pictures below). Glad I made the effort to fix the problem correctly.

Point noted about the sump. I can't face it to the rear as per the norm, as I need that space directly behind the fuel cell for a box that will house the air ride compressor, air manifold, battery, and other accessories that I want to be hidden. The chassis sits at a slight forward rake, and I have angled the fuel cell down so the sump is being gravity fed. Between that and keeping the tank full, I think the incline problem is for the most part mitigated. It is good to know about the 90* bends on the suction side of the pump. I'll be sure to note that for the future. Thanks.



1959Ford is offline  
post #7 of 9 (permalink) Old 08-06-2007, 06:49 PM
dfree383
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Spin the cell around and you have a winner.

The intention of the sump is to direct the fuel to the pick-up under acceleration, even though you have relocated the pump you still have the same issue that you had before, the pump is going to have to fight to get fuel. If your going to do it that way you might as well just leave the pump where you had it.......

DO IT RIGHT THE FIRST TIME !!!! You'll be changing it later after a few hard runs........
post #8 of 9 (permalink) Old 08-06-2007, 07:20 PM Thread Starter
 
Join Date: Jun 2007
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Okay- I hear ya. Let me see what I can do about space allocation behind the cell, and see if I can get it turned around. Thanks for watching my back.
1959Ford is offline  
post #9 of 9 (permalink) Old 08-06-2007, 08:47 PM
Senior Member
 
Join Date: Dec 2006
Location: Boise, Idaho
Posts: 765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I really have nothin usefull to add here, however.......I think you deserve an atta-boy!!! :lol:

From what i can see in the pics, it looks like you're buildin a really bitchen ride. We all really like pictures, so be sure to update.

mike
dirt_worker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome