1400HP T56? - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 10-18-2007, 05:12 PM Thread Starter
Senior Member
 
Join Date: Jul 2006
Location: Cheraw, SC
Posts: 724
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
1400HP T56?

Was bored sitting around the house today and stumbled upon this on evilbay.
http://cgi.ebay.com/ebaymotors/ws/eB...m=180170583791

That led me to find this company.
http://www.promotionpowertrain.com/index.html

Maybe I have been hiding under a log too long. Anybody ever heard of them? They have a long list of credits to their name.
Monstermiler is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-18-2007, 05:31 PM
Senior Member
 
Join Date: Jan 2006
Location: San Jose, CA
Posts: 2,185
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Wow

Pretty interesting claims...

I'd compare the guts of that box to a Tranzilla T56...which is like $6500 with your exchange. Ouch.

www.RaceSystems.com
Home of Project Ludicrous Speed
ByronRACE is offline  
post #3 of 4 (permalink) Old 10-18-2007, 05:34 PM Thread Starter
Senior Member
 
Join Date: Jul 2006
Location: Cheraw, SC
Posts: 724
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I noticed they charged a $350 core charge
Monstermiler is offline  
 
post #4 of 4 (permalink) Old 10-18-2007, 05:38 PM
Senior Member
 
Join Date: Jan 2006
Location: San Jose, CA
Posts: 2,185
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
$350

Too bad there isn't some way you could offer a $500 core charge for anyone that wanted to ship you a T56 instead.

I got my T56 from a Viper owner that thought it was bad because it was squeaking in neutral. He ordered a new tranny, had the speed shop replace it and it still squeaked. Pilot bearing.

I was there, asked him what he wanted for the old one, he said $500, I left with it.

www.RaceSystems.com
Home of Project Ludicrous Speed
ByronRACE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome