Picture of New Force Boss 500 Engine - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 12-08-2007, 09:36 AM Thread Starter
Member
 
Join Date: Jan 2006
Location: Lithia Springs, Ga.
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Picture of New Force Boss 500 Engine

Scroll down thru the pictures on this web. http://dragracingonline.com/livecove..._11-pri-1.html

Michael
Bracket Racer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-08-2007, 10:58 AM
Senior Member
 
Join Date: Jul 2006
Location: CSA
Posts: 285
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
good find. cant wait to see it in action
30over429 is offline  
post #3 of 5 (permalink) Old 12-09-2007, 09:51 AM
Senior Member
 
Join Date: Jan 2006
Location: KY
Posts: 518
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
$

They really make that stuff look pretty for the show!

Masters Degree in Perverted Idiocy.
LivermoreDave is offline  
 
post #4 of 5 (permalink) Old 12-09-2007, 11:13 AM
Senior Member
 
ThndrChkn's Avatar
 
Join Date: Apr 2006
Location: Helena,Montana
Posts: 3,195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Too bad that by the time NHRA got done with it they're left with nothing more than the old standby Hemi with Ford Racing stickers on it

Some of the stuff I heard about the original Ford designed motor was that they were laying down top qualifying runs first time out, so can you imagine that NHRA would make 'em change it :shock:

Doug... 8)

[SIGPIC][/SIGPIC] '86 F150... 521 w/ FRPP SCJ Heads, Glide...
Best ET: 1/8---6.17 @ 112 mph N/A @ 1200'
6.34 @ 112 mph N/A @ 5000'
1/4---9.73 @ 136 mph N/A @ 1200'
9.97 @ 135 mph N/A @ 5000'
ThndrChkn is offline  
post #5 of 5 (permalink) Old 12-09-2007, 12:51 PM
kim
Senior Member
 
Join Date: Jan 2006
Posts: 1,266
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 


Isnt the belt guide/tensioner on the wrong side of the belt?




I would think the scoop inlet, lower shield would extend a little further forward to prevent the belt turbulance from being a problem.. Then again, at 300mph....... hell... who knows what that scoop samples for air?????
kim is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome