Found the Problem with the Fire System - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 05-27-2009, 07:57 PM Thread Starter
Senior Member
 
jmayabb's Avatar
 
Join Date: Jan 2006
Location: Campton, KY
Posts: 686
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Found the Problem with the Fire System

I replaced the cable in the fire system tonight and found out why the cable wouldn't release. The cable housing goes through the head of the extinguisher and the cable is supposed to slide through the housing. A set screw also goes in the head to hold the housing tight while the cable will still move. We had the set screw tightened on the cable instead of the cable housing. This should have been checked when installed but I guess it was overlooked. A tip for everyone, put your pin in the head to disarm the system and see if your pull cable will still work.

I also installed a manual extinguisher behind the driver's seat just in case something like this ever happens again. Thanks again for everyone's help, I just wanted to let you know what caused the system to not activate.

Here is the bracket system that I installed on my car for the new extinguisher. This is one of the most trick pieces I have put on the car. It has a quick release pin that pulls it from the mount. I have these in stock by the way.


Joe's Race Parts
From Mild to Wild...
And Everything In Between
www.joesraceparts.com
www.joemayabbracing.com
jmayabb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-27-2009, 09:09 PM
Senior Member
 
billandlori's Avatar
 
Join Date: Sep 2006
Location: Stratford, Ontario Canada
Posts: 2,013
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thats some good info. I'm glad you could find the cause of the malfunction. Its scary whe you have no idea what caused the issue.

Nice detective work!!

Good luck getting her back in action soon!!

Bill

I salute our troops. Thanks for your service.

"The Key Board Warriors"

1983 Thunderbird
Big Block Power
466 Edelbrock Performer RPM heads, cam, intake
billandlori is offline  
post #3 of 3 (permalink) Old 05-28-2009, 11:32 AM
Senior Member
 
Phantasea466's Avatar
 
Join Date: Jan 2006
Location: Lawrenceburg, KY
Posts: 6,697
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Joe,

I need one of those fire extinguisher bracket deals, shoot me a PM or an e-mail

Thanks



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Damon Sea
1983 Mustang
534ci

"If it doesn't fit, Force it. If it breaks then it needed to be replaced anyway"
http://photobucket.com/albums/f75/Phantasea466
Phantasea466 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome