HELP NEEDED-need info on a 69 LTD w/429 - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 07-07-2009, 09:23 PM Thread Starter
 
Join Date: Jun 2007
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Unhappy HELP NEEDED-need info on a 69 LTD w/429

Hello, im in need of some info on a 69 galaxie ltd. Im having trouble getting the car to run right and it seems electrical in nature(the problem). Need to know if there are any modules or resistors hidden anywhere that im missing somehow? Ive tried everything i can think of.
wont idle at 700,omly at over 1000 and then it seems like missing,but will run,however,when in drive and going it will stall out,sometimes backfire. Idiot lites come on and engine is off like you turned it off. Ive changed the ign. switch and its pigtail,changed back to a stock type points dist,have gone over all wires i can get to. At first i thought it was electrical problem,but now im not sure? This problem started out as a one time thing every now and then to quickly getting more and more frequent in a random way. I changed the fuel filter and am now thinking of changing the fuel pump,which is only 3 to 4 yrs old,and changing the carb.,but those really dont seem tp be things that would get steadily get worse over time,they would either work or not. Looking for insight hopefully from someone who knows these cars. Thanks so much,
numanoid is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-07-2009, 09:33 PM
Senior Member
 
56tbird's Avatar
 
Join Date: Feb 2007
Location: Hawesville,Ky.
Posts: 2,960
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
How many miles are on it? You might want to check your timing chain and gears. Sounds like it may have jumped a tooth.

Dan Hobbs 2004 Super Pro Champion Windy Hollow 2002 NHRA National Dragster Challenge Super Pro Champion Beech Bend Raceway Best ET 5.290 @ 132.95 1.14 60 Ft. 575 injected alcohol 2008 & 2009 BBF Bash PRO Champion(The Guy With 2 BIG Checks)2010FunFord Super Pro Winner @Norwalk,Oh. 2011 NHRA National HotRod Reunion Gas Eliminator Champion..2012 Ford Thunder Q-16 Heads Up Champion

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
56tbird is offline  
post #3 of 3 (permalink) Old 07-07-2009, 09:39 PM Thread Starter
 
Join Date: Jun 2007
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
just turned 100k. I drove this car home from illinois in 07 when it had about 96k on it. Ran great until one time i was going along at about 75 mph and the idiot lites came on and before i could get it into neutral,she backfired big time. Pulled it over,threw it in park,started her back up and continued along. Since then it has slowly crept in,happening more and more frequently over time,but very randomly? Thats why i beleive its something electrical like a module or resistor,but i dont find anything like that. The voltage reg. was replaced before i got her,about 3 yrs ago id guess. Is it possible that the holley carb is going bad due to the 2 or 3 backfires it has had?
numanoid is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome