Ceramic coated header stains? - 460 Ford Forum
Chilly's Garage A place for non-460 banter.

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 11-12-2009, 09:58 PM Thread Starter
Senior Member
 
mudbogtom's Avatar
 
Join Date: Nov 2006
Location: Arizona
Posts: 1,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Send a message via Yahoo to mudbogtom
Ceramic coated header stains?

I recently got a set of ceramic coated headers with some bad oil stains on them. I haven't tried cleaning them yet, but is there something that will remove the oil marks without damaging the coating?

Thanks
Tom
mudbogtom is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-12-2009, 10:13 PM
Member
 
Join Date: Oct 2008
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
What I used

I have a set of ceramic chromed headers. I used Simple Green on a scotch brite pad followed by non-abrasive chrome polish. Worked great. Test on a small area first.
bossofu is offline  
post #3 of 5 (permalink) Old 11-14-2009, 12:32 AM Thread Starter
Senior Member
 
mudbogtom's Avatar
 
Join Date: Nov 2006
Location: Arizona
Posts: 1,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Send a message via Yahoo to mudbogtom
Thanks for the advice... I will give it a try before they get installed.

Tom

Soon to be powered by...
www.carsbycarl.com
mudbogtom is offline  
 
post #4 of 5 (permalink) Old 11-15-2009, 07:53 PM
Senior Member
 
Join Date: Mar 2006
Posts: 1,718
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
That's a common problem you have there. To prevnt that mess in the future (on newly coated headers), make sure they're super clean (NO oily residue or fingerprints) when you fire 'em up the first time. Wipe 'em down with alcohol or other such solvent.

The older I get, the smarter Dad was.
Maverick is offline  
post #5 of 5 (permalink) Old 11-15-2009, 08:09 PM Thread Starter
Senior Member
 
mudbogtom's Avatar
 
Join Date: Nov 2006
Location: Arizona
Posts: 1,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Send a message via Yahoo to mudbogtom
Note taken... if I ever get a new set, will do. This was a used set I came across, looks like the previous owner didn't have a pan gasket at all.

Thanks,
Tom

Soon to be powered by...
www.carsbycarl.com
mudbogtom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome