Fleetwood 460 engine bog - 460 Ford Forum
Engine Tech Archive A collection of all posts from the old Network54 forum

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 08-24-2015, 06:27 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Fleetwood 460 engine bog

I have a 1989 Fleetwood 37J with a Ford 460 engine. Problem I have is when under load I cannot get it past .15 MPH. At idle the engine runs great. I thought it might be the ignition module but thought I would try to get someexpert advice first. I have only had the RV for a few months and it did do this a little but now it is all the time. I tried letting the engine warm up first but it didn't help. Any advice provided would be greatly appreciated.
thom is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-20-2018, 07:18 PM
Junior Member
 
Join Date: Jun 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My 460 had the same problem climbing hills. I replaced the ABS sensor (single one on the pumpkin) and it's good now! ABS sensor acts like a shift sensor which mine does not have on the trans.
rmoons is offline  
post #3 of 3 (permalink) Old 04-15-2018, 09:51 AM
Junior Member
 
Join Date: Nov 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
No ABS on that chassis.
Sounds more like plugged fuel filter or failing fuel pump.
Replace the fuel filter and check fuel pressures.

DOH! Just realized this is an old thread in an Archive forum. Oh well, maybe it will help someone else.

Regards, Nick
460 in a 1995 F53 chassis motorhome.

Last edited by Nick-B; 04-15-2018 at 10:04 AM.
Nick-B is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome