spring rates (coil overs) - 460 Ford Forum
General Race Tech All other topics, such as Fuel Delivery, Ignition, Engine, Safety, Data Aquisition, Suspension, etc...

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 10 (permalink) Old 04-03-2010, 07:28 PM Thread Starter
Member
 
wheels123's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 247
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
spring rates (coil overs)

Have a Fox Mustang Drag car only, sportsman cromemolly cage, ladder bars, tube k-member, putting a BBF (iron heads) and C-6 in from a turbo SBF (aluminium heads).
What spring rate for the front coil overs do you recomend?
Car sat at ride hight with just empty block, heads and intake.
wheels123 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-07-2010, 05:17 AM
Senior Member
 
crittersf1's Avatar
 
Join Date: Aug 2008
Location: newport NC
Posts: 4,607
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
 
Send a message via AIM to crittersf1 Send a message via MSN to crittersf1 Send a message via Yahoo to crittersf1
Question

You do know that the smallblock C-6 will not bolt to the 385.

If you're not living on the edge you're taking up too much space!
crittersf1 is offline  
post #3 of 10 (permalink) Old 04-09-2010, 07:34 AM
Senior Member
 
Join Date: Jan 2006
Posts: 1,317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
 
d and d motorsports in kali suggested 14 inch 175 pound spring for me. bobn
zephyrbob is offline  
 
post #4 of 10 (permalink) Old 04-09-2010, 11:03 PM
Senior Member
 
Join Date: Jan 2006
Location: ohio
Posts: 562
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
race only...14-150
wayney is offline  
post #5 of 10 (permalink) Old 04-14-2010, 08:59 PM Thread Starter
Member
 
wheels123's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 247
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
springs

I have the drive train in and have 14-150 springs on now. It is low and I am concerned about handling on big end. UPR recommended 14-175, but seemed not enough?
Let me know what is being used out there.
Thanks
wheels123 is offline  
post #6 of 10 (permalink) Old 04-19-2010, 12:00 PM
Senior Member
 
waterslinger's Avatar
 
Join Date: Jan 2006
Location: merritt Island fl
Posts: 403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
pre-laod the spring one inch

605ci Big Block, 2 Speed J.W. Trans. w/4800 stall, 9" rearend 3.89 gear, 4-Link suspension,

1/8 mile 5.84 @124.5mph

http://www.geocities.com/ryan98gt/fordzilla.html
http://www.geocities.com/waterslinger1
waterslinger is offline  
post #7 of 10 (permalink) Old 04-20-2010, 02:11 PM Thread Starter
Member
 
wheels123's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 247
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
springs

Do you mean pre-load the 150 springs 1 inch?
Thanks
wheels123 is offline  
post #8 of 10 (permalink) Old 05-21-2010, 08:20 PM
Member
 
stang93mustang's Avatar
 
Join Date: Mar 2009
Location: Elgin, Illinois
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Yes....adjust them up 1 inch, it will raise the car back up.

I use 14-175 in front and 14-110 in the rear. Works well for me in weight transfer, I just need to find a smaller shock itself. I don't have much travel at all.

93' LX hatch, 460 with mods and factory heads, TH400 trans, 9" w/ 3.89 spool. Best (so far!) of 10.04 @ 133 mph w/ 1.36 60'
Wanna see a low budget BBF run: (I know..the date trips me out!)

https://www.youtube.com/watch?v=70l4...e_gdata_player
I'm not SAYING, I'M JUST SAYING!!!
stang93mustang is offline  
post #9 of 10 (permalink) Old 05-23-2010, 09:39 AM
Senior Member
 
Join Date: Jan 2006
Location: Cuba MO
Posts: 5,316
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 185 Post(s)
 
That's right use the coil over adjuster to set ride hight. Spring rates should never be used to set ride height on a race car.

Any sufficiently advanced technology is indistinguishable from magic --Arthur C. Clarke

Dave McLain
McLain's Automotive
DaveMcLain is offline  
post #10 of 10 (permalink) Old 05-24-2010, 11:39 AM Thread Starter
Member
 
wheels123's Avatar
 
Join Date: Jan 2008
Location: Tulsa, OK
Posts: 247
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
springs

I switched to 14-175 springs with same adjustment as 150's. I think the 150's were worn out.
Tested car for first time last week, after three shake down easy runs it ran 10.532 @ 129.1 w/ 1.53 60'.
This was with the struts set pretty tight about 3/4 (tight) turn from old setting. Front was not unloading at all and tires were struggling for traction.
I would think the 60' should be in low 40's or high 30's. Testing this weekend so we will see, I am starting at 2 turns out on struts.
wheels123 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome