F100 Traction problems - 460 Ford Forum
Race Talk Tech and Non Tech Discussion

User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 07-22-2018, 06:46 PM Thread Starter
Member
 
Join Date: Feb 2017
Location: Oregon
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
F100 Traction problems

So I took my truck to the Medford 1/4 dragstrip yesterday for the first time since I got it back together. I’m having some traction problems though and I was hoping for some advice. I’ve searched all over but can’t really find want I was looking for. Truck is a 66 F100 short bed 3900lbs with me in it. Motor is 460 .40 over SCJ heads and RPM intake with work done by the Mad Porter Cam is also from him. Suspension is DJM drop beams with new stock springs and DJM shocks rear is set up with factory leafs with one leaf removed and DJM rear shackle kit and DJM shocks. Rearend is Ford 9inch with 3.89 gears and locker. I installed cal tracs had 1/2 turn preload for first 2 passes and then went to 1 full turn preload still no luck I’m running mickey Thompson et street r’s 315/50-17. The rest of the night I tried longer burn out shorter burn out but no luck to get it to hook. I was foot braking it to about 2200. Any advice would be awesome. Here is a video of one 60 ft was 1.82..

https://youtu.be/XTiWN8ZSa7w
66F100466 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-23-2018, 12:41 PM
Junior Member
 
rbro1275's Avatar
 
Join Date: Jul 2017
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
 
How much air you running before a pass??
rbro1275 is offline  
post #3 of 4 (permalink) Old 07-23-2018, 09:21 PM Thread Starter
Member
 
Join Date: Feb 2017
Location: Oregon
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
 
First pass and the pass in the video were 24lbs then I dropped them down to 20lbs with no change in the way it hook
66F100466 is offline  
 
post #4 of 4 (permalink) Old 11-27-2018, 11:04 AM
Member
 
Join Date: Feb 2008
Posts: 221
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
 
The one thing I don't see is weight transfer and with a pickup I wouldn't expect it with the weight bias. I would throw 100 lbs or so in the bed, drop your tire pressure to 15 psi or so and test.
slowride is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 460 Ford Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome