460 Ford Forum banner

Reaction score
0

Profile posts Latest activity Discussions About

  • badass545 ·
    Got mine to start for couple minutes . Shut her off. Ticking noise from #7-8.... Slow crankin but it started ... Turn off. Won't start anymore ..
    badass545 ·
    Well thx. Mine are 8.68".. It came with the motor... Ill have to take my intake out n see what's goin on the a ticking noise coming from the #7-8 cylinder .. Hopefully it's nothing major .. Well my motor set is almost the same as your . Only it's a 545...
    customblackbird ·
    Ummm I need to check. They where off the shelf BBC moly 3/8" pushrods. I'll let u know. I want to say 8.55" or something, I know the exhaust is .100" longer.
    customblackbird ·
    Yea i got it running. Ive been having issues with High RPM popping. But i got it all figured out. I took it out and the thing was a total beast and only got to 4500ish. I just swapped my stealth intake for a edlebrock torqer II for alittle more RPM power but havent taken it out bc of rain.

    How bout you?
    badass545 ·
    Hope u the new carb works out for u.. I got my 1000 cfm super mod from AED.. They wet flow the carb n everything... Hope I don't run into any bugs ..
    badass545 ·
    Hey bird.. Do u have any videos of your motor.. I working on 545 with 61605 cam. Edelbrock 75cc heads... Haven't started mine yet.
    aquartlow ·
    Hello Customblackbird,
    If I may ask you some questions about a C6 servo you possibly used I would really appreciate it. I see that you, in a few transmission threads, were possibly going to use the Superior brand super servo for your C6. I need some info that I haven't been able to find. Thank you, Todd
  • Loading…
  • Loading…
  • Loading…
Top