460 Ford Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
I have a problem with the overdrive button when it is pushed it makes the speedo and tach and gas feed useless and it blows a 10 amp fuse #45 run feed. Never ever had a problem with this truck until tonight coming home from work. Anybody have any ideas.
 

·
Registered
Joined
·
895 Posts
Button

Just had the tow/haul button(shifter) changed out on my 04 as it quit working, wires were all cracked where it went into the steering column. Never caused any other problems just didn't work. By parts numbers there are three different types and of course had to go thru 2 before the third was the correct one. lol Mark L.
 

·
Registered
Joined
·
1,979 Posts
It's the wires chaffing in the metal gearshift tube. If you can't get a replacement you can disassemble the top cover of the column and unplug the wires, then pull them out of the column shift tube.

This would allow you to at least tape them and just plug it back in without the column assembled. This would be the "get ya home" fix if you need it...

But, it's a very common problem. Be sure to check out www.fordtrucks.com its a great site and has helped me alot with my pickups over the years.
 

·
Registered
Joined
·
185 Posts
Discussion Starter #5
Thanks for the info I will probably fix it myself with some solder and some shrink tube. Or maybe since its my truck I'll route another button in the little hole right in front of your right knee so its not in the steering column just leave the old button in the shifter.
 

·
Registered
Joined
·
902 Posts
Recall

I see Ford finally had recall on this problem, causing fires on some trucks. Now you can get it fixed for free if you want to go thru the hassle of taking it to the dealership .
 
1 - 7 of 7 Posts
Top