460 Ford Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6,697 Posts
Discussion Starter #3

·
Premium Member
Joined
·
1,733 Posts
Damon,
Thanks for posting,

I think I have a high speed air bleed problem, engine pulled clean up through about 6100 rpm ,then went into a lean miss. plugs were hard to read. but the more jet I threw at it the less it missed and the more hp it made.

Richter69, here goes the numbers :oops:

458 hp @ 6500
397 tq @ 5600

Sounds kind of sad huh, I see people with a lot bigger hp numbers, not running as fast at the track. The last time I was at the track, it ran in the low 6.40's and it dynoed 450 hp , so go figure.

I think his dyno is way conserative, or At least I hope .

I will know more if I get to dyno with Damon Thursday.




Blake
,
 

·
Registered
Joined
·
6,697 Posts
Discussion Starter #5
Blake,

You're glide is holding you back on the HP numbers too. My friend Derrick sprayed his 393CI SBF with a 150 shot on the dyno and made something like 460 to 480 RWHP (Don't remember the exact number) and he's running a glide. I made 560 N/A RWHP on the SAME dyno and we both ran similar numbers at the track in the 1/8 mile. He ran a 6.37 and I ran a 6.38 :wink:

We'll get it fixed Thursday :idea:



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Premium Member
Joined
·
1,733 Posts
Damon,

That makes me feel more warm and fuzzy 8)

I hope it will pick up some more hp when I get the miss out of it.

Kind of disheartning when you see people with right at 600 hp running low 6,s and you only have 450


Blake
 

·
Registered
Joined
·
6,697 Posts
Discussion Starter #7
1 - 7 of 7 Posts
Top