460 Ford Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
seems like every time i think ill finaly get to compete something else breaks. was testing things out on the bronco. new motor. well refreshed w new solid 530 lift mech cam and some more port work on the doves. at first i was running the victor ive had on it for years and was real impressed w the throttle responce and power. ran it around our hooptie of a track about 20 times. then i convenced myself that the stealth i got from bryan (nucularcobra) would pull harder so i swaped em. honestly i have to say it felt much better w the vic. the thing seemed to just run harder. after about 20 laps i started hearing a buzing noise. trans temp was 190 but i fel the trans starting to go. ill shorten this up. friggen cheap *** tci convirter blew up. so i guess all the problems i had with the tci valvebody are gone now to. i was geting it ready to run in the tough truck show in spokane this weekend now ill just go watch....... mabie ill win the lotery then i can get it ready for moses lake sand drags. NOT:mad:. remeber every one its leaghbor day weekend. SUPPORT OUR TROOPS YOUNG AND OLD.
 

·
Registered
Joined
·
2,013 Posts
I feel for ya Red Neck!!

It sucks when you think everything is done, then..............what's that noise.............oh sh*t!!!

I had that with my T-Bird and the trans with a TCI VB. the thing sucked ***!! I ended up getting a stock VB and with Frank Merkl's help, the thing shifts great now. I only got to drive it maybe 200 miles last year. Gonna wear it out this summer!!

Good luck, hope you can get it fixed soon!!

Bill
 
1 - 3 of 3 Posts
Top