460 Ford Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
I am just starting a new thread. I was able to tighten the band but it looks tweaked. It goes crooked when it gets tight. I'm guessing it had too much pressure on it when the servo was sticking. So I can not find a 2 1/2 wide Kevlar band. Where do I get it. I have a Ford Racing wide ratio kit so I think I have a 6 pinion forward planetary and I think it came with some Torrington thrust washers. I was thinking of upgrading the rear planetary to 6 pinion and not sure where to get that. I want to rollerise what I don't already have. I think the 6 pinion rear kit might come with some bearings. I may upgrade the clutch packs also. I appreciate all the help you guys give !!!

Thanks
Pat
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
OK thanks, The valve body is being bench tested at Hughes Performance. I think it is OK but the line pressure was sort of high. 250 at 2000 and they said it relieves at 275. I want to make sure the relieve valve is working. It had 100 psi in reverse. It didn't push the transbrake button. The band goes crooked when tight so I am going to replace it. I got to go pull the tranny out and pull the guts out. It has been worked on three times now by Hughes Performance. They had a good Ford guy but he quit. He rollerized it and a ford racing wide ratio kit was put in. So until I get it apart I don't what else needs to be done. I will take pictures and post them. Pat
 
1 - 6 of 6 Posts
Top