460 Ford Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
I'm running a Performance Automatics SuperComp C4 behind my 521BBF. So far the car has only seen about 200 miles on the street, still sorting it before I hit the 1/4 mile. I've yet to give it a WOT launch, due to lack of traction with street tires, but have noticed that with about 1/2 throttle or more the 2-3 gear change will slip. The engine picks up a few revs during the gear change, and the change takes maybe 1 sec, whereas all other gear changes are firm and instant. It has only just started doing it recently. The gearbox has a full manual rev pattern valvebody with transbrake, though I do not have the transbrake wired up yet. Is this problem a symptom of something serious, or is it just a band adjustment required?
Any advice I can get before I take it to a trans shop would be much appreciated. Thanks.
 

·
Registered
Joined
·
38 Posts
I believe it is commenly reffered to

as the 2/3 flare and if you call performance automatic I am sure that they will be able to solve the problem for you. Every time that I have called them with a question they have been very helpful. I have a PA c-4 behind my 545 and it has over 100 passes on it and still works good. The engine is out of my car this winter to paint and detail the compartment so I will also check the trans as long as I have everything out. It just makes sense as the engine is at almost 700 hp and I will be spraying it this summer. :D
 

·
Registered
Joined
·
445 Posts
c4-valve body

I had that problem with a Godley c-4. I tried the bands with no luck. I dropped the valve body,sent it to Godley, he cleaned and checked valves and springs, dynoedit and sent it back to me. And it cleared up. But now PA don't want you to do that, they want the whole trans I think.
 

·
Registered
Joined
·
460 Posts
Try This

Todd, If you still have the problem, Remove the spring in the front servo. If it has one. Adj the band 1 turn out If it has corse thred on the adj. Let me know what happens. Sometimes on a C4 2-3 flare just removing the spring will fix it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top