460 Ford Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
I’ve been searching and haven’t really found what I was looking for. My truck has a built 460 in it and driving normal my C6 transmission will shift manually normal 1 to 2 to 3 no problem. At the track I can foot brake it to about 2k and when I let off I get a split second of 1st and straight to 2nd with out me shifting it. 2nd to 3rd is a normal manual shift. At first I thought it was my shifter doing it because it’s a rod style with the shifter mounted to the cab and possible frame twist would cause it to shift with out me doing so. But the geometry of how it’s set up would actually cause it to downshift so I’ve ruled that out. This transmission is completely stock. Need a shift kit? Different style valve body? Any help would be appreciated thanks
 

·
Registered
Joined
·
2,300 Posts
Yes a shift kit will cure that . A transgo 67-2 kit modifies the scheduling valve with a stiff spring. Have also seen spacers in there to block that valve moving

A shift kit will help the trans live and crisp up the shifts , a stock valvebody shifts way too slow
 

·
Registered
Joined
·
82 Posts
Discussion Starter #3
Thanks Greg I’ll look into it I have heard good things about them. I should have mentioned the shifter I’m using is a Lokar. I was also looking into the Performance Automatic street/strip valve body they offer. I’m running the B&M trick shift fluid also
 

·
Registered
Joined
·
2,300 Posts
You can modify your valvebody without the expense of replacing. A shift kit is the easy way.

My understanding is some valvebodies will skip right to 2nd in manual 1st, the scheduling valve is responsible. Most of the shift kits modify it.
There are mods to the accumulator valve and servo reg valves to firm the shift + drilling the oil feed for the 2-3
 

·
Registered
Joined
·
82 Posts
Discussion Starter #6
Bringing this back up lol. I made it to track yesterday for the first time this season and I’m having the same issue. Early 1-2 shift when trying to manually shift the tranny. I put a PA street/strip valve body in it. I tried a pass in D and it held 1st a little longer but the shifts were pretty much back to back. If I try and manually shift when I launch it instantly shifts into 2nd. On the street I can hold 1st as long as I want but I have no traction and I’m not hooking like I do at the strip. I don’t have the kick down hooked up would this cause this? Any pointers would be helpful
 

·
Registered
Joined
·
2,300 Posts
At this stage be best talk to P.A , see exactly what they have to say.

I'd be interested what they consider "Street/Strip".
Reason I say that is , Many years ago I was interested in their 750 HP C4 pro-street trans . I contacted them if they did a kit for the valvebody to replicate that setup.

The reply was YES , so i ordered a kit . Was moreso for my own research :)

Anyway what turned up was the absolute very basic Transgo SK-C5 shift improver kit.

So yeah be interested to see what they have done to your valvebody. As I suggested above I believe the mod to the scheduling valve is required to cure the issue you had.

If the valvebody you have is nothing more than a shift improver setup sold as 'Street/Strip" then that kit doesn't really address the scheduling valve
 

·
Registered
Joined
·
82 Posts
Discussion Starter #8
Thanks Greg I sent an email yesterday to them see what the say. Little frustrating but I was still happy with what it ran with out first. 12.90’s at 106 really want to see what it really has.
 

·
Registered
Joined
·
526 Posts
Call me crazy but I thought when a C6 was shifted to 1,it went to 1 and stayed in 1.I've had a bunch of them...stock,all kinds of different VB kits,etc,never had one short shift to 2 in manual low. In D,yes for various reasons but not in manual low.
 

·
Registered
Joined
·
2,300 Posts
Call me crazy but I thought when a C6 was shifted to 1,it went to 1 and stayed in 1.I've had a bunch of them...stock,all kinds of different VB kits,etc,never had one short shift to 2 in manual low. In D,yes for various reasons but not in manual low.
I agree I’ve not had it myself either. But then I rarely leave a valvebody stock. Many years ago I did and really for me just shifted way too soft.
I have read of quite a few over the years that say they have had it. What I’ve mentioned above I believe is the fix.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #12
So I got a response today from PA. They want me to pull it out and send it in so they can look at it and fix the problem. Out another 60 bucks on ATF. They really didn’t tell me what could be causing it. I’m gonna play it safe and order the Lokar cable conversion for my shifter. I still have my stock Valve Body that I might put the kit in you recommended Greg.
 
1 - 13 of 13 Posts
Top