460 Ford Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Finally made it out last night and i'm really disappointed. After fighting three different carbs and a vacuum leak we finally got it to at least drive decent, but it was definitely down on power. Not to mention that the converter would only go 4200 on the brake. 60 foots were terrible all day. Best pass of the day was 6.58 @ 104.7 with a 1.438 60.
I went and picked up a used 1050 this morning to hopefully solve the carb problem. The converter's probably gonna have to stay for now until after the bash. Unless of course someone wants to give me one. LOL. Here's a video so you can see how big of a turd it really was.

 

·
Registered
Joined
·
132 Posts
Discussion Starter #4
Yeh another problem I was having was the three step didn't seem to be working right, if I put in a 6300 chip in it it would cut out at 5900 according to the tach. Not sure it it was the tach or the three step. I finally put in a 6800 chip and I was crossing the traps at 6300.

I had the converter built here locally at champ converters. Never had a problem with it in my old set up but this is totally different from that deal. After the bash I'll probably buy something about 5500 stall.
 

·
Registered
Joined
·
6,970 Posts

·
Registered
Joined
·
6,392 Posts
Converter sounds tight, but i'd sort the carb out first, it should still run good with the gear and tire size you have.

Put some alky on it..............;)
 

·
Registered
Joined
·
6,970 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #13
First on the list is getting the carb fixed then work on the converter. I'm thinking 5000-5500 stall should do the trick, i'll just have to turn up the shift point a bit.
 
1 - 16 of 16 Posts
Top