460 Ford Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,195 Posts
Good job Ken. Boat sounds great. With a little practice you'll get better on the lights.






Doug... 8)
 

·
Registered
Joined
·
590 Posts
Great job Ken !!!
I could not catch the ET or MPH.
Boat looked good, I bet it would be a hair quicker if you could hold that nose down abit at the launch. BP would be a good guy to talk to on that.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #5
Thanks guys.

Jim, It was the first race, and setup was nowhere near right. Getting the nose up is the idea, that way when it lays over you should be on top of the water and going. Problem is, it is shooting clear out of the water and unloading the pump. Usually does it twice. If you can carry the nose across the starting beam, the beam hits you at the transom instead of the front of the boat & shaves a little ET. Been working on it, and it's getting better.

I think the ET was 10.89 @ 89.44

Charlie, you got my curiosity up now! LOL Are you guys going to be at the green this year???

Ken
 

·
Registered
Joined
·
226 Posts
Congrats on your first race, drag boat racing is the best. I used to run a Comp Eliminator flatbottom (sorry guys it had a 500 ci chevy in it) with the ADBA and SLDBA, we were running on a 9.50 index with a best pass of 9.29. Had to give up the boat thing once most of the races here in the midwest dried up but I still really miss it and all the people. I wish I knew how to post a pic of the boat, at any rate have fun and stay safe.
 
1 - 6 of 6 Posts
Top