460 Ford Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello, im in need of some info on a 69 galaxie ltd. Im having trouble getting the car to run right and it seems electrical in nature(the problem). Need to know if there are any modules or resistors hidden anywhere that im missing somehow? Ive tried everything i can think of.
wont idle at 700,omly at over 1000 and then it seems like missing,but will run,however,when in drive and going it will stall out,sometimes backfire. Idiot lites come on and engine is off like you turned it off. Ive changed the ign. switch and its pigtail,changed back to a stock type points dist,have gone over all wires i can get to. At first i thought it was electrical problem,but now im not sure? This problem started out as a one time thing every now and then to quickly getting more and more frequent in a random way. I changed the fuel filter and am now thinking of changing the fuel pump,which is only 3 to 4 yrs old,and changing the carb.,but those really dont seem tp be things that would get steadily get worse over time,they would either work or not. Looking for insight hopefully from someone who knows these cars. Thanks so much,
 

·
Registered
Joined
·
2,960 Posts
How many miles are on it? You might want to check your timing chain and gears. Sounds like it may have jumped a tooth.:eek:
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
just turned 100k. I drove this car home from illinois in 07 when it had about 96k on it. Ran great until one time i was going along at about 75 mph and the idiot lites came on and before i could get it into neutral,she backfired big time. Pulled it over,threw it in park,started her back up and continued along. Since then it has slowly crept in,happening more and more frequently over time,but very randomly? Thats why i beleive its something electrical like a module or resistor,but i dont find anything like that. The voltage reg. was replaced before i got her,about 3 yrs ago id guess. Is it possible that the holley carb is going bad due to the 2 or 3 backfires it has had?
 
1 - 3 of 3 Posts
Top