460 Ford Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
Hey all. Im upgrading my Front Engine Dragster but before I go for my net launch I want to check out what you all think of my launch. The new motor makes a whole heap more power, and includes a transbrake. Foot braking and launching at approx 2500 rpm lead to the car squating down (as in the picture) and then taking off. The new motor will make approximately 100-150 hp more off nitrous, plus were moving from a C6 to a Glide with a transbrake.



There is a whole heap of tyre distortion in the pic.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #4
The new motor is a 545 Stroker:
Edelbrock performer RPM CJ heads (74cc) (heads off my old motor, not ported)
4.5 Stroke Scat cast crank
6.7 Probe forged steel rods
Probe forged flat top pistons
Reed roller cam 545-RX303-R310ULX-110A2
Running duration in 303 ex 310
Valve lift in .702 ex .721 @1.73 RR
Duration @ .050 tappet height in 269 ex 274
lobe centers110
but my rockers are 1.7 ratio i think.
Victor manifold.
Currently a 950 holley, but that will be making way for a dominator as soon as I decide between methanol or gas

Compression is around 13.5:1

I think it should make 660hp +

Plus im switching from a C6 to a glide - i believe i should pick up probably 40-50hp at the rear wheels from that change.

Plus i still have the nitrous to go on top :)
 

·
Registered
Joined
·
2,013 Posts
I assume this has no suspension in the rear. If that is the case, about all you can play with is tire pressure and launch RPM.

I think you can expect some pretty heavy tire distortion with the big torque your making and hitting it off a trans brake.

Not much help I'm afraid:(:)

And yes, we are jealous!!! Cool car!!

Bill
 

·
Registered
Joined
·
195 Posts
Discussion Starter #6
Yep, No suspension. That was from the original 528 motor with a small solid flat cam (think it was 0.598 and 0.615 lift) and about 10:1 compression ratio. Launching at about 2500 rpm with 7.5 pound in the tyre usually now (although we played with tyre pressure that weekend so may have been slightly lower). At the time that would have been with the C6 and no transbrake... im excited about giving this new motor a try, should have a load more power... estimating its capable of about an 8.3 off the bottle, and then who knows what if i started adding the nitrous. I heard a few guys with similar setups hitting with 300-400 hp of nitrous... Wonder if i could make a 7?
 

·
Registered
Joined
·
2,013 Posts
Sounds like a 7 should be within reason.

Must be quite a ride!! Seeing as how they are in between your legs, I hope you have good driveline parts!! :eek:

Some video would help with the launch information.

Bill
 

·
Registered
Joined
·
195 Posts
Discussion Starter #8 (Edited)
Rear end is made up of a stock case narrowed with a brace, Strange carrier, Moser spool, 33 Spline Moser shafts and 3.89 pro gears. Over the top of that I have a steel protective cover running the width of the cockpit and extending down to the tailshaft of the C6 which is made from either 2mm or 3mm steel, and the seat base is also 6 mm alluminium.

So far I have only run down into the 9.2's at 145, and usually the car launches and drives pretty straight, however last meeting we found out the hard way that we had a problem with our tyre pressure guage when it started weaving and then bouced around to approximate 45 degrees towards the wall across the other lane at between the 1/8 mile and 1000ft mark (so i would say at about 130 mph). I caught it and kept it in the lane but boy was that a wild run... and it still ran a 9.25 @ 121 mph (would have been around a 9.11 looking at the timing data). I have a picture from the run and it seems to me that the rear left tyre was off the floor up past the finishline. We found that there was 5.5 psi in that side, and 7.5 in the other...

Ill try and get some video's, I have a couple of onboard shots but i dont think they will tell you anything.

http://www.youtube.com/watch?v=-jipyzDt8KE

That run was a 9.37 launching in 2nd on the C6 (as we had a gearbox issue)

Not sure of the time on this pass:
http://www.youtube.com/watch?v=mnb3hRXTzrI
 

·
Registered
Joined
·
2,013 Posts
Yikes that sounds pretty scary!!

Summit sells a dual hose/chuck gauge so you can set both tires exactly the same, I'm sure it could be made easily enough too. It has one guage with a "T" and two long hoses with the tire chucks on each end.

Bill
 

·
Registered
Joined
·
941 Posts
Up the pressure a little a time (on each side lol). Go up 1/2 lb at a time until it spins and then back off 1/4-1/2 lb. As long as it doesn't get into tire shake, the distortion is nothing to worry about.

A pic of mine with distortion, but I never felt it. 4.68 @ 146.5 1/8 mile with a 1.03 60'
 

·
Registered
Joined
·
195 Posts
Discussion Starter #14
The whole car has been built on a very tight budget by myself and my father - only things we have had made by someone else are the gearbox and the propshaft (yeah, i know i should have a greek coupler!). The headers were originally made for a door car and pointed out 90 degree's to the side, so we chopped them and cut down the angle to about 45 degrees and turned them to point upwards. Im going to try and clean them up a bit for next season. The cost me around $600 and that was all the budget i had at the time...

This is the first car we have ever built, and our first 460 motor so were learning a lot. On launch she feels like she squats and digs in and then flies... i really cant argue with the performance. We had a 1.27 60ft with a 3500 stall convertor and the C6 on a 9.2 second pass.

Thanks for the suggestions, well try a bit more air next time out.

I think that the car weighs around 1900 - 2000 lbs with me in it. Its a mild steel chassis and is overbuilt.

And I actually looked at the picture and thought I was waving too... but im not, my hand is right behind my ratchet shifter ready to punch for 2nd. I only wave during the burnout, as its something one of the european top fuel racers used to do that I was a fan of when i was younger. Just getting ready for the new motor - and the ability to burnout over the start line... as you can see my burnout is pretty short right now.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #15
Well, the new motor expired before even making a run down the track :-(

Looks like we actually snapped a valve which then dropped and snapped again, taking out the block, and damaging the piston and head at the same time.....


So now we have a new build

552 Ci, Forged pistons with the same crank and rods and cam, new block 60 thou over, new oil pump and sump, Ford Racing SCJ Heads - Thanks Lem, with a Rons Flying Toilet thanks to Killer Rons! Methanol here we come... Ran it through some simulation software and we should be looking at Very low 8's or high 7's without the nitrous.
 

·
Registered
Joined
·
2,013 Posts
Sorry to hear about the hurt engine:( Hate when that happens.

New package sounds like a wild build!!

Let us know!!

Bill
 

·
Registered
Joined
·
195 Posts
Discussion Starter #18
Ran my first 8 this weekend :). The first full pass in the car was as follows.
index 8.90
reaction 0.0136

60ft 1.2637
330 ft 3.6589
594ft ET 5.3239
1/8th ET 5.6972
1000' ET 7.4525
1/4 ET 8.9547

1/8 MPH 120.56
1/4 MPH 149.08



3 runs later and I sheared the output shaft off the planetary on my glide :-(



On inspecting the glide it was near stock, and the clutches were already pretty well burned just 4 runs in!

I have a new glide though - apparently it can take up to 1800hp internally, but the input shaft will only take 1200... not bad for me though as the most I can see my motor putting out is 770. We dropped the new glide in hoping to make eliminations, but it looks like there is a problem. We fired her up and while Park was fine all the other shift locations result in the wheels being driven forwards - including reverse and neutral. Also 1st seemed like it was binding in some way as when you shifted into it the wheels stopped spinning. We werent comfortable in diagnosing so we called it for the weekend, and will be talking to our transmission expert - but I think it was probably just the band being too tight.
 
1 - 20 of 20 Posts
Top