460 Ford Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
I have a 850 dp on my car list 9380 everything seems to be ok except i cant get it to idle below 1300 rpms i seem to recall a few years ago having this problem and i ended up drilling a small hole in the to primary butterflys and this fixed the problem problem is i cant remember the size hole is this a good fix or is there somthing better i can do
 

·
Registered
Joined
·
1,170 Posts
You should be able to get it to idle below that point. I would be looking real hard for a vacuum leak.

The reason people drill a hole in the butterflys is because too much of the transfer slot is exposed. If that's not your problem, I wouldn't do any non-reversable mods to it.

Have a good day!
Michael
 

·
Premium Member
Joined
·
1,957 Posts
I am using a 9380 on a 545, and had it on a 466 previously. Without any drilling on the throttle plates, it idled great with a large cam and a Victor intake....Even with an auto tranny!

I agree that either the secondaries are not closing fully or there is a vacuum leak.

Good luck,

Greg
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #5 ·
vacume lk

Yall are right I have a bad vacume lk somewhere, when the engine gets warmed up i cant idle it down past 1300 rpms if i do it dies. When i set the idle at 1300 rpms it will idle up to about 1800 rpms and back down
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top