460 Ford Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
New member here & happy to be a part of the 460 family! I have a 7.5L 460 EFI in a 1990 F250 Lariat XLT dual tank w/57K miles on it. I love this rig but it recently started misfiring (idling & running rough) and I could use some advice. I suspect that I may have clogged fuel injectors in cyls 3 & 6... diagnosed this by removing each wire individually (1x1 in order) from the dist cap and noticed that all of them caused idle to worsen when unplugged except 3 & 6 (no change to idle). Wondering if I need to replace those two injectors as my next troubleshooting step or try cleaning them first. Also, the truck sat for a while with gas in the tanks, but I added fuel stabilizer to both tanks during that time & replaced the fuel filter prior to running it again. Note: I replaced all of the following as part of my initial troubleshooting process (nothing helped)...
  • Fuel filter (below driver’s side door)
  • O2 sensor between the exhaust manifold & muffler
  • 3-terminal manifold absolute pressure sensor
  • Distributor cap & rotor
  • Fuel injection pressure regulator
  • New plugs
  • New air filter
Thanks for any advice you guys have on this issue!
 

·
Registered
Joined
·
13 Posts
New member here & happy to be a part of the 460 family! I have a 7.5L 460 EFI in a 1990 F250 Lariat XLT dual tank w/57K miles on it. I love this rig but it recently started misfiring (idling & running rough) and I could use some advice. I suspect that I may have clogged fuel injectors in cyls 3 & 6... diagnosed this by removing each wire individually (1x1 in order) from the dist cap and noticed that all of them caused idle to worsen when unplugged except 3 & 6 (no change to idle). Wondering if I need to replace those two injectors as my next troubleshooting step or try cleaning them first. Also, the truck sat for a while with gas in the tanks, but I added fuel stabilizer to both tanks during that time & replaced the fuel filter prior to running it again. Note: I replaced all of the following as part of my initial troubleshooting process (nothing helped)...
  • Fuel filter (below driver’s side door)
  • O2 sensor between the exhaust manifold & muffler
  • 3-terminal manifold absolute pressure sensor
  • Distributor cap & rotor
  • Fuel injection pressure regulator
  • New plugs
  • New air filte
Best online casinos list https://niconewmedia.com with casino review and welcome bonus. Try to win jackpot by playing viseo slots.
Thanks for any advice you guys have on this issue!
Welcome to the forum, mate!
 
1 - 2 of 2 Posts
Top