460 Ford Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
4,396 Posts
Discussion Starter #1
First off I borrowed a trailer and decided to tow the truck rather than drive it. (save a little gas)

So I get to the track, make a pass and noticed that I am out of fuel! But, the truck ran a 8.90 & 75mph 1.90 60ft! So, I get this brillant plan to run some 112 race gas! Make another pass and my mph drops to 72!! So I decide to hot lap to make sure that this was right!
I leave the starting line, then notice my truck isn't shifting! Huh?? (What gear is it in?) About 550' out I realize it left in 2nd! It ran the whole 1/8 mile in 2nd and ran a 9.3 @ 72 with a 2.00 60 ft! Opps!!

So, I let the truck cool for 2 hours. I get back in and decide to make another pass. Except, this time I am going to shift it! (Brillance) I leave in 1st, shift to 2nd, then 3rd???? 3rd???? jiggle??? !!!WOOOAAA!!! "neutural" 8,000rpm here we go!!
Ouch,, trailer here we come!!

It only made some funny noise in the shut down, then it cleared up!


I wonder what I should check??
 

·
Registered
Joined
·
519 Posts
C6 Problems

Check the linkage first.
Also if 3rd is gone and reverse is gone that is usually an indicator that you lost a band.
If parts scatter they will go thru the pump and make a gravely sound.
You can put it into gear with the parking brake on and hear the pump which is just behind the converter. If you hear unusual noises drain the pan and check for solids in the fluid.
 

·
Premium Member
Joined
·
4,396 Posts
Discussion Starter #3
I am going to put my street tires on and drive it around some this evening and get that crappy 112 race gas out of it! I should be able to get a better idea of it's condition.

Note: IF you have a low compression engine and get lazy and not want to leave the track for 93 octane, but instead use 112 leaded race gas, don't! My throttle response went to crap and lost 3mph!
 

·
Registered
Joined
·
3,730 Posts
right about the fuel. correct fuel for the engine is best, found out the lowest octane the engine can tolarate better performance. if you hear any noise on start up , pull the valve covers. save gas, thats funny
 

·
Premium Member
Joined
·
4,396 Posts
Discussion Starter #6
I took my slicks off and went for a drive around town this evening. Truck seemes down on power but shifted ok. Until, I got close to home and decide to make a 1st through 3rd pass. First thing I noticed was it would spin the street tires. Shifted into 2nd but no 3rd! :( So I let off and turned around. It never would go back into 3rd. Engine got hot so I idled home (about a mile) also noticed a slight whine.

Oh well the shift kit rebuilt 2,600 stall lasted almost 1/4 of the race season.
 

·
Registered
Joined
·
96 Posts
I had a similiar experience in my '67 Fairlane. It had a C6 in it and it consumed the high-gear clutch on a pass at the races. It had completely sheared off the front of the drum where the retaining ring for the clutch plates was. All the plates were shattered into 1/4" - 1/2" pieces. The cool part was that it was all still together in the clutch drum and was lifted out as though it was still assembled. It looked like a jig-saw puzzle. I'm strictly a manual trans guy now. Just got my first Liberty Z.

Cliff
 

·
Registered
Joined
·
1,642 Posts
Cliff,Do you know if Liberty Transmissions has a website.

A friend of mine thought they had a website but couldn't find it anywhere.

Thanks Mark.
 
1 - 8 of 8 Posts
Top