460 Ford Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
Pulled the glide out of the car last night. 10 total 300' passes on it. Fluid is so acrid it gags ya. Found out today that the shaft has broke free of the pump. Only splined and pressed in from the factory. So actually the shaft is spinning in the pump and a obviously the pump is still working a little. Amazingly the car still moved. No idea when this happened, but also noted that the hub on the TCI torque convertor is a bright blue. Like it has been extremely hot. We have heard of the pump shafts breaking but have never seen one break. Is this what normally happens or does the shaft actually break? Anyone have any other suggestions what we should look for when tearing this thing apart?
 

·
Registered
Joined
·
177 Posts
Blue Cyclone said:
Pulled the glide out of the car last night. 10 total 300' passes on it. Fluid is so acrid it gags ya. Found out today that the shaft has broke free of the pump. Only splined and pressed in from the factory. So actually the shaft is spinning in the pump and a obviously the pump is still working a little. Amazingly the car still moved. No idea when this happened, but also noted that the hub on the TCI torque convertor is a bright blue. Like it has been extremely hot. We have heard of the pump shafts breaking but have never seen one break. Is this what normally happens or does the shaft actually break? Anyone have any other suggestions what we should look for when tearing this thing apart?
Bryan, correct me if I"am wrong but are you talking about the pump sprag?If so most are pressed in and can spin inside pump housing causing extreme heat and proably hurt the covertor.I would tear tranny down check everything real close.The converor sprag will need replaced and internally inspected.It is not uncommon for the tranny to still try and pull.If this was a new pump then seller should replace it for you and should repair your convertor to.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
Ray, you are correct it was the pump sprag. I have a buddy going thru everything t see shat else may be damaged. He has run glides for 20+ years behind a big chubbie and has never seen this happen. Any ideas? We have a lot of concerns about replacing the pump and having the same thing happen again.
The pump was a stock pump, but had been turned down and bushed for the turbo convertor. Therfore no warranty. Same bud did this work. We new he was scared we'd outrun him, but don't believe he would sabotage us. Ha Ha!
 

·
Banned
Joined
·
4,325 Posts
Blue Cyclone if you have to send the converter in to get it checked out you can solve your problem have them put in a front stator bushing in your converter so you don't have to run a bushed pump for your shaft


Randy
 

·
Registered
Joined
·
177 Posts
Blue Cyclone said:
Ray, you are correct it was the pump sprag. I have a buddy going thru everything t see shat else may be damaged. He has run glides for 20+ years behind a big chubbie and has never seen this happen. Any ideas? We have a lot of concerns about replacing the pump and having the same thing happen again.
The pump was a stock pump, but had been turned down and bushed for the turbo convertor. Therfore no warranty. Same bud did this work. We new he was scared we'd outrun him, but don't believe he would sabotage us. Ha Ha!
Bryan,yours makes the third I have seen.PTC and other co.s put new sprags in their pumps as well as bushing.You have to remember we are doing things with these trannys that was never invisioned when designed.This as well as age proably caused failure.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #6
Ray: We have a new higher volume pump ordered along with a wider band since they are availible, and new clutches. Nothing else so far has looked bad, actually the clutches and band didn't really look hurt at all but decided to go with new anyhow. What are your thoughts on the convertor? We are thinking about just cleaning the convertor out and trying it. Not hard to get to with this chassis.
 

·
Registered
Joined
·
177 Posts
Blue Cyclone said:
Ray: We have a new higher volume pump ordered along with a wider band since they are availible, and new clutches. Nothing else so far has looked bad, actually the clutches and band didn't really look hurt at all but decided to go with new anyhow. What are your thoughts on the convertor? We are thinking about just cleaning the convertor out and trying it. Not hard to get to with this chassis.
If there was no metal in tranny it could be ok.I would clean it out as best you can and look for metal put your shaft in and make sure the torrington bearing feels good to.also make sure sprag did"nt swell and fits pump good and you should be fine hope this helped.
 
1 - 7 of 7 Posts
Top