460 Ford Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,426 Posts
Discussion Starter #1
Went to San Antonio, Tx last week and checked things out a bit, then had to find out what the drag race scene is like.
The track is pretty good from what I could gather, fresh racing surface that gets prepped the right way!!
Actually, they told me that the whole complex is only about year and a half old!
Went there for a "midnight madness" event and seen some pretty cool stuff.
I'll be moving there probably before the year is over.
Any big block Ford'ers in the San Antonio area on this site??
 

·
Registered
Joined
·
36 Posts
The track's actually about five years old. Opened in '00 or '01, IIRC. There are lots of us in the central Texas area. BigBlockBob lives about halfway between Austin and SA, down around Canyon Lake, and there are four or five of us here in Austin.

We're real proud of our track.....it's a treat to be able to race at a first class facility, especially when you consider where we had to go before SAR opened up. The Midnite Madness races are a blast.....be sure to check out Clash of the Titans and, of course, the Nationals coming up at the end of the month.
 

·
Registered
Joined
·
1,033 Posts
TorinoStyle2 said:
Went to San Antonio, Tx... ...I'll be moving there probably before the year is over.
Any big block Ford'ers in the San Antonio area on this site??
Come on down! Just don't bring any of them tree-hugging Californians with you... There's already plenty of them here. :roll: :wink:



BigBlockBob
 

·
Registered
Joined
·
2,426 Posts
Discussion Starter #5
We'll do! thanx for that warm Texas welcome! hopefully, the tree huggers stay in their own place while I quietly slip out the back door into a place of freedom, LOL.
 

·
Registered
Joined
·
4 Posts
San Antonio

Yeah, I remember racing at the Hwy 16 track back in '86/'87. They used to have High School night out there at Hwy 16, does anyone know if they have that at the new track?

I used to go out there with some friends that raced the Candy Apple red BUDWEISER Nova. I believe it was a '69. That car had a 427 in it and ran a 9.63 @ 132 mph. No bottle for that run. It was done at the Kmart event they had out there. Not sure if it was a Nats type event or not.

I am currently in VA working for Uncle Sam and I will be back in San Antonio sometime next year. I can't wait to get home where I belong. :p

Love that weather too. :D
 
1 - 6 of 6 Posts
Top