460 Ford Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter #1
well i finally made it to the track again after 6mo of chemo rehab and pulling the 512 checking bottom end, installing complete msd sys, and replacing line loc,master cyl, calipers, lines, pads, yea this time i'm i got those 9:40 slips in the bag! yea right! the front brakes were locking up on me again and i put it on the trailor after i shut down the track to work on the car. :oops: this is the second time. don't know why the front right brake for no reason decides to engage or never fully release posted details on gen.tec.
 

·
Registered
Joined
·
474 Posts
You don't happen to have a residual pressure valve in the front brake circuit do you? If you do that may cause the line lock to fail to release pressure to the brakes. I have a friend who had that happen to him even without the residual pressure valve. I'd lose the line lock and see if the problem goes away. What brand is the line lock? We had a similar problem when using a Major brand line lock.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #5
the only thing between the calipar and mastercylender is a 5 circut porportional valve not sure if this is what ya calling residual valve. my line lock is feed from the back line of the master c, (large resivor) the output of the line lock goes to the rear top of the proportion valve the two ports in the rear of the pro. valve one coming out of the bottom the other stright out the back go to the front brakes. i beleave if the line lock was locking up again it would be both wheels. i once experienced this and bought a new one and thought i had the problem solved??
 

·
Registered
Joined
·
948 Posts
brakes

Another not uncommon cause for brakes not releasing is a brake line coming apart internally and acting as a one way valve.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #10
2slow said:
line lock should after p/valve. check hose to caliper, if factory part they are known to do that
the line lock is plumbed in between the m/c and p/valve so this i can correct the p/valve is a factory stock, unit what do i replace it with.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #11
richter69 said:
so got any timeslip data or video? pics?
yea i got a couple but i can't make any thing out of them, would post them if i though any one could. i was having to back way off the throttle and allow the car to get back in the track then nail it again i do know that at 80mph it will get away from ya if ya nail it. this could be related to the brake/brakes grabing i don't know.
 
1 - 11 of 11 Posts
Top