460 Ford Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter #1
What rpm should I be launching at?
This is a f150 4x4 mud truck. Shift point is 5200rpm and rev limiter is at 6200. BBF, c6 combo, 3.50 gears, 38.5" boggers.
I made a couple test launches in my driveway with the 2 step @ 3000rpm and it seems like this rpm is too low. I'm new with transbrakes so just not sure what to do.
My second ? is should I mash the gas pedal to the floor or just bring it up to the 2 step before I launch?
Since it is all new to me I'm open to any suggestions.
Thanks
mike
 

·
Registered
Joined
·
1,161 Posts
pull the chip out of the 2 step , push transbrake button and mash accelerator to the floor , see where the rpm's go too, then let us know what it stalls at. :lol: Always launch on the floor.
 

·
Registered
Joined
·
6,970 Posts
ky mustang said:
pull the chip out of the 2 step , push transbrake button and mash accelerator to the floor , see where the rpm's go too, then let us know what it stalls at. :lol: Always launch on the floor.
so i guess ive been lauching the car all wrong cause when i do that Randy it goes to about 4300--- i have my 2 step set at 4300 :? doh i guess i need to lower it huh???? maybe that why my 60' suck and when i spray it the 60' dont really change much !!!!



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
264 Posts
Discussion Starter #6
Well I tried a 3600 pill in the 2 step.
When the light turned green I was at full throttle and let off the button.
The 9" rear broke as soon as the button was released.
Not sure what broke yet but it looks like it needs upgraded before I try it again.LOL
mike
 

·
Registered
Joined
·
1,329 Posts
ky mustang said:
I would say you need to play with it to see what the car likes. Mine stalls to about 5800 and I have a 4600 rpm chip in the 2 step. I need to step it up a bit though and try it :lol:
This is true............mine will stall 5200, but i leave with a 3600 chip.

The hit is more violent than leaving at an rpm that is closer to stall point......
 

·
Registered
Joined
·
264 Posts
Discussion Starter #10
Ky it is stock other than a 31 spline mini spool and hardened pin.
The driveshaft turns by hand with a little resistance just no wheel movement. I think the pin may have sheared.

Frank I'm sure the 9" won't be the last weak link. I figured the ujoints would be first to go.

Moser engineering is here in Indiana and I have been looking at my options with their parts.
 

·
Registered
Joined
·
895 Posts
9"

I run Franks Tranny Brake and come off the two step at 4400, torque kicks in around 4700 and hang on gone like a rocket. I mud race so it is a little more forgiving with a 31 spline, 5.38 ratio, 38" boggers with a Lincoln locker 9". LOL

Later Mark L.
 

·
Premium Member
Joined
·
3,225 Posts
Hey Mike, put a full spool in and use 1350 U-joints. End of weak stuff hopefully. 31 spline axles are pretty stout pieces, but even they have their limits. ThndrChkn Doug in Montana has some good axles for sale in the Auction Block. 8)
 

·
Registered
Joined
·
255 Posts
Like the other guys have said, you need to test and see what RPM it likes the best. When you unplug the 2-step and find the converter stall don't forget reconnect the 2 step. I forgot and the end of the track disappeared :shock: :shock: when i let go of the button. Most of the converter guys say 600 to 800 below whatever your converter flashes too. It just depends on traction/suspension.

Get that rear-end fixed and go have some fun :!:

Mark
 

·
Registered
Joined
·
787 Posts
P.Lafferty said:
Get your self a good nodular 3rd member. With big block power its not hard to blow caps off a 9in. with out a brake :lol: Pat..
exactly.i blew the caps off a couple stock housings then put a strange in and it's been good since.now,the broken strange axle surprised me but.........
 
1 - 15 of 15 Posts
Top