460 Ford Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
well im running a moroso 63595 on my car and it S#@T the bed today after 30 passes. what should i look at for the next one or should i go with the same thing ???? i know there a quality pump
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
im goin to have to do some investigating . i want something i can change without taking all the water pump bolts out off the plate .... beside getting a remote mount and spending to much more on lines&fitting .
 

·
Super Moderator
Joined
·
4,936 Posts
im goin to have to do some investigating . i want something i can change without taking all the water pump bolts out off the plate .... beside getting a remote mount and spending to much more on lines&fitting .
You can take the CSR pump off by removing 4 bolts. And they are not the bolts that hold the backing plate on or go through the timing cover in any way. The electric pump detaches from the rest of the mechanism with 4 bolts.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #8
you see the cars running the belt drive and they dont run the backing plate they just bolt it to the engine plate .. think ill call csr tomorrow and see what they say .
 

·
Super Moderator
Joined
·
4,936 Posts
you see the cars running the belt drive and they dont run the backing plate they just bolt it to the engine plate .. think ill call csr tomorrow and see what they say .
It could very well work like that. The more I think about it I think that the backing plate is flat on the front and that would be the same as the motor plate.
 

·
Registered
Joined
·
2,387 Posts
I run the CSR pump and it's been working great in the mud that my truck sees. I swapped motor plates as the original had the cutout for the stock style pump and since I didn't want to run the extra bolt in plate that would be needed, I got a plate from S&W racecars that didn't have the center hole. Makes for a cleaner look to me.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #11
got it apart, the pump was rubbing against the backing plate . glad i work in a machine shop ill lazer cut a new plate outta 12gauge. pump is still working was just hung up.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #13
found more out, you have to mill the engine plate .20 . so the impleller clears properly .i take the blame on this one ...
 
1 - 14 of 14 Posts
Top